通过vlan+静态路由配置路由

通过vlan+静态路由配置路由

我在配置网络时遇到问题。我在交换机之间创建了 VLAN:5、6、9 和 10。VLAN 9 是本机 VLAN。PC1 在 VLAN 5 中,PC0 在 VLAN 6 中。我配置了 R1,使其能够通过不同的 VLAN 进行通信(从 PC0 到 PC1 的 ping 操作正常)。现在我想从 PC1 ping R3 se0/2 接口,但没有响应。以下是我的配置文件:

开关S1:

Current configuration : 942 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet1/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet2/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet3/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
!
interface FastEthernet9/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

开关S2:

Current configuration : 830 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet1/1
!
interface FastEthernet2/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet3/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
 switchport access vlan 6
 switchport mode access
!
interface FastEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

开关S3:

Current configuration : 830 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S3
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet1/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet3/1
!
interface FastEthernet4/1
!
interface FastEthernet5/1
!
interface FastEthernet6/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet7/1
 switchport trunk native vlan 9
 switchport mode trunk
!
interface FastEthernet8/1
 switchport access vlan 5
 switchport mode access
!
interface FastEthernet9/1
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

路由器 R1

Current configuration : 1039 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/0.6
 encapsulation dot1Q 6
 ip address 192.168.6.1 255.255.255.0
!
interface FastEthernet0/0.9
 encapsulation dot1Q 9
 ip address 192.168.9.1 255.255.255.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

路由器 R2

Current configuration : 649 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.2 255.255.255.0
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

路由器 R3

Current configuration : 690 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.1 255.255.255.0
 clock rate 64000
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

路蒂格表,R1:

R1#sh ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.2 to network 0.0.0.0

C    192.168.5.0/24 is directly connected, FastEthernet0/0.5
C    192.168.6.0/24 is directly connected, FastEthernet0/0.6
C    192.168.9.0/24 is directly connected, FastEthernet0/0.9
C    192.168.10.0/24 is directly connected, FastEthernet0/0.10
S*   0.0.0.0/0 [1/0] via 192.168.10.2

路蒂格表,R2:

R2#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0

路蒂格表,R3:

R3#sh ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.1.2 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
S*   0.0.0.0/0 [1/0] via 172.16.1.2

我的拓扑:http://s6.ifotos.pl/img/screen6pn_xwqenpw.png

如何更改我的网络配置以便能够从 PC0/PC1 ping 到 172.16.1.2 或 172.16.1.1?

答案1

我无法添加评论,但据我所知,您没有从 PC0/PC1 到达 R3 的路线。

您可以从 PC0 到达 PC1,因为它们在某种程度上连接到同一个网络,即使连接到不同的 VLAN。您需要在整个网络中构建一个路由表,以便您的 PC 可以到达 R2/R3。

您需要添加的基本路由是将 172.16.1.0/24 指向 R2 的内部 IP 地址。

相关内容