我想浏览所有已加书签的行并复制它们。
这将是按 F2 然后按 Ctrl+D 的自动方法。
我已尝试使用宏和两个 \1 以及正则表达式进行查找和替换。
---------------------之前的示例------------------------
hostname RTA
interface Loopback0
ip address 203.250.13.41 255.255.255.0
interface Ethernet0
ip address 203.250.14.1 255.255.255.0
router ospf 10
network 203.250.13.41 0.0.0.0 area 1
network 203.250.0.0 0.0.255.255 area 0.0.0.0
上面有 8 行代码。我标记了第 2 行和第 4 行。
------------------------示例之后-----------------
hostname RTA
interface Loopback0
interface Loopback0
ip address 203.250.13.41 255.255.255.0
interface Ethernet0
interface Ethernet0
ip address 203.250.14.1 255.255.255.0
router ospf 10
network 203.250.13.41 0.0.0.0 area 1
network 203.250.0.0 0.0.255.255 area 0.0.0.0
答案1
我对此的解决办法不太优雅:
- 在每个书签行中添加“##BOOKmarked LiNe##”
-在 vbs 文件中运行以下命令
-删除所有“##BOOKmarked LiNe##”条目。
outFile="C:\Users\user\Desktop\test_loop1-out.txt"
Set objFSO=CreateObject("Scripting.FileSystemObject")
Set objFS = CreateObject("Scripting.FileSystemObject")
Set objFileout = objFSO.CreateTextFile(outFile,True)
Set objFile = objFS.OpenTextFile(strFile)
Do Until objFile.AtEndOfStream
strLine= objFile.ReadLine
objFileout.Write strLine & vbCrLf
if strLine.contains("##BOOKmarked LiNe##") Then objFileout.Write strLine & vbCrLf
Loop
objFile.Close
objFileout.Close