我有一台 Mikrotik Router RB951G。我在这两个网络上设置了两个热点:
- 192.168.1.0/24
- 192.168.2.0/24
我还创建了两个用户配置文件:
- 客人
- 员工
我已经在访客配置文件中配置了带宽限制。另一方面,我想在员工配置文件中配置每日数据下载限制。
我已经运行了这两个脚本来执行此操作,但似乎不起作用。
限制数据的脚本
#Set your dowload limit in MegaBYTES! :local downloadlimitmb "250" ### You will not need to edit anything below this line ### :local downloadlimit [($downloadlimitmb * 1048576)] :local counter :local datadown :local username :local macaddress :foreach counter in=[/ip hotspot active find where user~"^[T][-].{17}"] do={ :set $datadown [/ip hotspot active get $counter bytes-out] :if ($datadown>$downloadlimit) do={ :set $username [/ip hotspot active get $counter user] :set $macaddress [/ip hotspot active get $counter mac-address] /ip hotspot user remove [/ip hotspot user find where name=$username profile=Employee] /ip hotspot user add name=$username limit-bytes-out=$downloadlimit mac-address=$macaddress profile=Employee /ip hotspot active remove $counter :log info "Force logout on user: $username - Reached download quota" }}
清除用户计数器的脚本
:log info "Checking Users" :local counter :foreach counter in=[/ip hotspot user find profile="Employee" ] do={ /ip hotspot user remove $counter }
最后我添加了两个时间表:
- 触发数据限制并每分钟运行一次。
触发 clearcounter 并每 24 小时运行一次。
每 24 小时运行一次