我正在尝试在办公室设置双 WAN,因为我们的单个 VDSL 调制解调器无法再处理我们的网络流量。因此,我们现在有两个 VDSL 调制解调器(Sagecom FAST2864),它们无法进入桥接模式,因为它们被我们的 ISP 锁定了。因此,我不得不禁用它们的 DHCP 和 WIFI,并在我的思科路由器上设置静态地址。
我的拓扑看起来像这样....
我的问题是,当两个链接都处于活动状态并且您尝试浏览互联网时,需要刷新 3 或 4 个页面才能加载所有内容。当我禁用其中一个链接时,一切都正常!我尝试过两者,但ip load-sharing per-packet
都ip load-sharing per-destination
导致完全相同的问题。我已将我的配置发布在下面,有关此问题的任何指导都将非常有帮助,因为我目前正在为闲置的额外 VDSL 连接付费。
!
hostname HWY404
!
!
memory-size iomem 10
ip subnet-zero
ip cef
!
!
ip name-server 8.8.8.8
ip dhcp excluded-address 10.1.1.1 10.1.1.100
!
ip dhcp pool COMPUTERS
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
dns-server 10.1.1.1
!
<!--OUTPUT OMITTED-->
!
interface ATM0/0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0/0
description BELL-1
ip address 192.168.2.200 255.255.255.0
ip nat outside
ip load-sharing per-packet
duplex auto
speed auto
!
interface FastEthernet0/1
description BELL-2
ip address 192.168.1.200 255.255.255.0
ip nat outside
ip load-sharing per-packet
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description LOCAL LAN
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip load-sharing per-packet
duplex auto
speed auto
!
ip nat inside source route-map BELL1 interface FastEthernet0/0 overload
ip nat inside source route-map BELL2 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
ip pim bidir-enable
!
!
!
route-map BELL2 permit 10
match interface FastEthernet0/1
!
route-map BELL1 permit 10
match interface FastEthernet0/0
!
<!--OUTPUT OMITTED-->
!
end
答案1
在这种情况下,您可以使用route-map
,为客户端组创建策略。类似这样的事情:
定义 ACL:
ip access-list extended FirstLink
permit tcp 10.1.1.10 any eq www
deny ip any any
定义路线图:
route-map FirstLan permit 10
match ip address FirstLink
set interface Fa0/0
将其应用于LAN接口:
interface FastEthernet1/0
description LAN
ip policy route-map FirstLan
但这需要您有另一个 LAN 接口 (Fa1/1) 以供其他主机通过。
为了在这种情况下实现真正的负载平衡,您可以使用韋爾/