我不确定我是否正确地表述了这个问题,所以对于由此造成的任何混淆,深表歉意。
我有两个路由器。路由器之间距离太远,无法使用电缆将它们连接在一起。
第一个连接到互联网,有一个单独的 wlan 接口。LAN 上的所有设备都通过 WiFi 连接到它。
第二个有两个 WLAN 接口,没有互联网连接。
这是 Cont7e 制作的图表,描述了我想要实现的目标(感谢!):
Windows 7 PC 通过 WiFi 连接到第一台路由器,通过以太网端口连接到第二台路由器。另一台设备暂时使用以太网连接到第二台路由器,因为我无法让它的 WiFi 正常工作。
我想以某种方式将第二台设备连接到互联网。
我已经在第二个路由器上安装了最小的 OpenWRT(并不是说我有使用它的经验),并尝试配置路由器以通过编辑其无线配置将其中一个 wlan 接口置于管理模式,如下所示:
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/ar934x_wmac'
option htmode 'HT20'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'wan' <--- tried both 'wan' and 'lan'
option mode 'sta' <--- changed to 'sta'
option encryption 'psk2' <--- encryption mode on other router
option ssid 'SSID' <--- other router's SSID
option key 'KEY' <--- other router's key
这并没有产生我预期的结果。
我尝试的方法总体上是好方法吗?我该如何实现它?
编辑:添加由 Cont7e 友情提供的图表
答案1
我终于解决了这个问题。我使用了一个名为的配置OpenWRT wiki 中的伪装。
两个路由器位于不同的子网。带互联网的路由器位于 192.168.1.1/24。第二个路由器位于 192.168.10.1/24。
无互联网的路由器使用 OpenWRT 配置。其中的“lan”条目/etc/config/network
如下所示:
config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.10.1' <-- make sure it's on different subnet
option netmask '255.255.255.0'
option ip6assign '60'
在同一个文件 ( /etc/config/network
) 中,“wan”条目不得包含ifname
条目:
config interface 'wan'
option proto 'dhcp'
现在我们需要配置 Wi-Fi 接口以连接到其他网络。编辑/etc/config/wireless
并修改wifi-iface
您要使用的无线电条目:
config wifi-iface
option device 'radio0'
option network 'wan' <-- 'wan' here
option mode 'sta' <-- 'sta' for station mode
option encryption 'psk2' <-- whatever encryption is used on other router
option ssid 'SSID' <-- SSID of the other router
option key 'PSK' <-- password of the other router
编辑两个文件后,运行:
# ifup wan
# wifi
现在您应该能够从连接到路由器的任何主机连接到互联网。