隧道接口上的 IOS QOS 服务策略直通

隧道接口上的 IOS QOS 服务策略直通

我在一个网络上有一些 SIP 电话,它们通过 IPIP 隧道到达服务器。

我已经设置了 QOS 规则来监视适当的 VOIP 流量,如下所示:

class-map match-any class-voice
  description Voice
  match  dscp af11
  match  dscp cs4 
  match  dscp cs3 
!
policy-map qos-out
  class class-voice
   priority 100
!
interface Tunnel1
 description Tunnel to VOIP Server
 ip address 10.10.0.2 255.255.255.252
 tunnel source FastEthernet0/1
 tunnel destination 172.16.100.100
 tunnel mode ipip
!
interface FastEthernet0/1
 description Internet
 bandwidth 1000
 ip address dhcp
 service-policy output qos-out

我的问题是由于我无法将策略分配给 Tunnel1,只能分配给 FastEthernet0/1,所以类映射无法匹配。

肯定有某种东西可以使其发挥作用...我该怎么办?

答案1

我很怀疑优先级队列能不能这样应用到隧道接口上。QoS功能适用于真正发生带宽竞争的对象——物理接口。

如果您的隧道仅用于 SIP 或其他高优先级流量,您可以将其全部匹配并添加到您的类映射中,如下所示:

ip access-list extended sip-tunnel
 permit ipinip any host 172.16.100.100
!
class-map match-any class-voice
  description Voice
  match  dscp af11
  match  dscp cs4 
  match  dscp cs3
  match  access-group name sip-tunnel
!

更新:在某些情况下,原始数据包中的 DSCP 字段会被复制到隧道头。您可以针对具体情况(Cisco + IOS + ipinip)选中此选项。如果成功,您不需要最后一个匹配初始配置应该可以正常工作。

相关内容