在 MikroTik 上屏蔽“ethash.poolbinance.com”

在 MikroTik 上屏蔽“ethash.poolbinance.com”

你能解释一下吗?我该如何在 MikroTik 的防火墙上阻止这个地址。

我只是尝试添加仅包含“poolbinance.com”的规则以及包含“ethash.poolbinance.com”的其他规则

但它不起作用。

谢谢你的帮助。

完整地址看起来像tcp://ethash.poolbinance.com:1800

答案1

如果您的路由器是客户端的 DNS 服务器,您可以定期轮询 poolbinance 的 DNS 缓存并阻止相应的 IP:

每 10 秒左右安排一次此脚本:

:global addIP do={
  :if ([:len [/ip firewall address-list find address="$nouvelleIP" and list="blockedIPs"]] = 0) do={
    /ip firewall address-list add list="blockedIPs" address=$nouvelleIP timeout=02:00:00
  }
}

:local myServers { "poolbinance" }
/ip dns cache all {
  :foreach i in=$myServers do={
    :foreach j in=[find where (name~$i)] do={
      :local myName [get $j name]
      :local myType [get $j type]
      :local myData [get $j data]
      :if ($myType = "A") do={
        $addIP nouvelleIP=$myData
       }

      :if ($myType = "CNAME") do={
        :local ipResolue [:resolve "$myData"];
         $ajouteIP nouvelleIP=$ipResolue
      }
    }
  }
}

然后添加防火墙规则来阻止来自blockedIPs列表的所有流量:

/ip firewall filter add action=drop src-address-list=blockedIPs

相关内容