我希望有人能帮助我。我有一个 AT&T 2wire 网关,其中有一个 cisco 路由器连接到 AT&T 2 wire 的端口 3。我将 CISCO 用作单独的网络和实验室。下面是我的网络草图和路由器的 show run config 输出。我的问题是我试图使用 NAT 通过 AT&T 线路从 cisco 路由器访问互联网。此外,当我执行 show nat 转换时,表中没有显示任何内容,好像没有转换任何内容,我无法访问互联网,但可以 ping 两个网络上的所有内容,10.1.1.0。192.168.1.0。我哪里做错了。
AT&T
|
|
192.168.1.111
| fa0/0 Outside NAT
|
CISCO Router
fa0/1 10.1.1.1 Inside NAT
Router#show running-config
Building configuration...
{Current configuration : 1039 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip dhcp pool Test_Lab
import all
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.111 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 101 interface FastEthernet0/0 overload
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.0
ip route 10.1.1.0 255.255.255.0 FastEthernet0/0
ip route 10.1.1.0 255.255.255.0 192.168.1.0
!
!
access-list 101 permit ip 10.1.1.0 0.0.0.255 any
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
Router#show ip route
Gateway of last resort is 192.168.1.0 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
S 10.1.1.0 is directly connected, FastEthernet0/0
[1/0] via 192.168.1.0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.1.0
将 IP 路由更改为 CISCO 路由器所连接的 AT&T 端口 IP 地址
Gateway of last resort is 192.168.1.93 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/1
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.1.93
答案1
我认为问题出在你的路由表中。例如,
ip route 10.1.1.0 255.255.255.0 FastEthernet0/0
ip route 10.1.1.0 255.255.255.0 192.168.1.0
根据这些命令,所有发往 10.1.1.0 网络的 IP 数据包将被重定向到 FastEthernet0/0(这意味着返回 192.168.1.111)或 192.168.1.0(这可能意味着无处可去,因为这是网络地址,而不是网关地址)。因此没有 IP 数据包可以到达 10.1.1.0 网络。
但是,我不确定这是否是个问题,因为 10.1.1.0 是直接连接的,它仍然可以正常工作。您能否将您的路由表添加到问题(“sh ip route”的输出)中?
答案2
我猜测 AT&T 有一个 LAN 侧 IP 地址,在这种情况下,您需要在思科路由器上创建一个默认路由,将所有目的地为未知网络的流量发送到 AT&T 盒上的 LAN 侧接口。
ip 路由 0.0.0.0 0.0.0.0 IPOFAT&TLANINTERFACE
这意味着任何“未知网络”流量(例如到互联网的流量)的下一跳都将被定向到 AT&T 路由器,然后 AT&T 路由器将流量转发到其上游网关。
除非您可以在桥接模式下操作 AT&T 并将您的公共 IP 分配给 cisco 上的接口,否则您不需要在 cisco 上执行 NAT。
答案3
可能是我误解了您的问题,但听起来您甚至无法从 Cisco 路由器 ping 通 Internet 上的目的地,那么这才是主要问题,而不是 NAT。由于您可以使用“show ip NAT Translations”查看翻译,因此听起来这部分配置已修复。
尝试从源接口 Fa0/0 ping 互联网上的目标。除了连接到 AT&T 设备的 Cisco 路由器之外,还有其他设备吗?它们能否访问互联网?
编辑:似乎您使用了错误的默认网关 IP。要找到正确的 IP,您可以使用笔记本电脑或 Cisco 路由器。
在笔记本电脑上:将其连接到网络并确保已打开 DHCP 而不是静态 IP。用于ipconfig
在分配的 IP 地址旁边显示分配的默认网关。可能看起来与此类似,或者可以显示更多信息,但无论如何,您都应该能够在 ipconfig 的输出中找到默认网关的地址。
https://i.stack.imgur.com/ezGAF.jpg
使用思科路由器上的默认网关的 IP 作为静态路由。
替代方案 2:在 Cisco 路由器上,您可以执行同样的事情:
enable
configure terminal
interface FastEthernet0/0
ip address dhcp
exit
no ip route x.x.x.x (make sure to remove every static route in your config just to have a more clean config)
end
show ip route
在输出中你应该看到
Gateway of last resort is x.x.x.x
,这是你的 AT&T 内部接口的 IP
当您找到哪个 IP 是您的网关后,您可以切换回路由器的静态 IP,并使用该 IP 作为默认路由。
答案4
我在接口 fa0/0 上创建了到公共 IP 地址的静态路由。当我show ip int brief
在 cisco 路由器上执行 a 时,我得到的 IP 地址是 192.168.1.254。
我将笔记本电脑连接到 fa0/1 接口,并从 CISCO 路由器上的 DHCP 获得 10.1.1.1.11 作为 IP 地址,然后我就可以上网了。所以看起来它正在运行。