在运行 openwrt 的哑 AP 上配置 OpenVSwitch

在运行 openwrt 的哑 AP 上配置 OpenVSwitch

我目前正在尝试在 OpenWrt 上运行 openvswitch。这是我尝试实现的设置:我有 2 个无线客户端连接到运行 OpenWRT 的 AP(我的接入点是 Netgear WNDR3700)。AP 是哑的。然后我将 AP 连接到 PI。PI 连接到互联网,并且正在运行 DHCP。最后,我在 PI 上运行 onos。

Onos 可以看到设备(ovs 交换机),也可以看到主机(两台笔记本电脑)。但主机没有分配任何 IP 地址。当无线接口被分配到 LAN 网络时,它们被分配了 IP 地址,但 onos 看不到主机。

============

以下是一些更新。我创建了一个 wan 接口 eth1.1,并将其添加到 ovs 网桥。我在 ovs 中添加了一条规则,将任何从端口 2(wlan0)传入的数据包推送到端口 3(eth1.1)。PI 连接到路由器的 WAN 端口。我在 ovs 网桥、wlan0 接口和 eth1.1 接口上执行了 tcpdump。我可以在 3 个接口上看到来自无线客户端的 arp 数据包……但是当我在 pi 的 eth1 上执行 TCPdump 时,我什么也看不到。

============

这里是/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd3c:8eef:8a02::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1 eth1 radio0.network1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.43.2'
    option gateway '192.168.43.1'
    option dns '192.168.43.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config interface 'wlan0'
    option proto 'none'

这是 /etc/config/wireless

config wifi-device 'radio0'    
    option type 'mac80211'    
    option channel '11'  
    option hwmode '11g'
    option path 'pci0000:00/0000:00:11.0'
    option htmode 'HT20'

config wifi-iface
    option device 'radio0'
    #option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

答案1

[已解决] 这是 /etc/config/network 中的更改

[Solved] here is the change in the /etc/config/network file: 
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd3c:8eef:8a02::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1 eth1 ovsbr'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.43.2'
    option gateway '192.168.43.1'
    option dns '192.168.43.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'
    option enable_vlan4k '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config interface 'wan'
    option ifname 'eth1.1'
    #option force_link '1'
    option proto 'none'
    #option ipaddr '192.168.43.4'
    #option netmark '255.255.255.0'


config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '3'
    option ports '3 5t'

config interface 'lan1'
    option proto 'static'
    option ifname 'eth0.3'
    #option auto '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'
    option ports '2 5t'

config interface 'lan2'
    option proto 'static'
    option ifname 'eth0.2'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '4'
    option ports '1 5t'

config interface 'lan3'
    option proto 'static'
    option ifname 'eth0.4'

config switch_vlan
    option device 'switch0'
    option vlan '5'
    option vid '5'
    option ports '0 5t'

config interface 'lan4'
    option proto 'static'
    option ifname 'eth0.5'

#config interface 'ovsbr'
#   option proto 'static'
#   option ifname 'ovsbr'
#   option ipaddr '192.168.43.3'
#   option netmask '255.255.255.0'
#   option type 'bridge'

config interface 'wlan0'
    option protocol 'none'

请注意,我已将 eth1.1、eth0.2、eth0.3、eth0.4 和 eth0.5、wlan0 添加为 ovsbr 桥的端口!:)

相关内容